YouTube Views Campaign Delays
Incident Report for devumi
Resolved
Our YouTube Views service is now in full swing. All campaigns should be moving forward.
Posted 3 months ago. Jul 09, 2017 - 16:52 EDT
Monitoring
Currently in final staging of completing our maintenance and analysis for our new YouTube Views service. Likely restarting existing orders and campaigns today.
Posted 4 months ago. Jul 06, 2017 - 08:47 EDT
Identified
Our YouTube Views service is currently undergoing maintenance & deep analysis as a result of a recent YouTube Algorithm update. Expect a temporary interruption of service for all new and active campaigns. Should be resolved within 48 hours.
Posted 4 months ago. Jul 03, 2017 - 12:22 EDT